GreenBrowser 论坛


 
标题: 【插件】朗读网页中选择的文本 [2007-10-31 加入循环朗读功能]
Jingle
大学三年级
Rank: 9Rank: 9Rank: 9


UID 5287
精华 6
积分 1741
帖子 469
阅读权限 200
注册 2007-6-5
来自 广东
状态 离线
发表于 2007-10-27 20:28  资料 短消息 
【插件】朗读网页中选择的文本 [2007-10-31 加入循环朗读功能]

【功能】使用 TTS 语音引擎朗读网页中选择的文本。

【技巧】
      1. 此插件有一个 GUI 选项框,如果隐藏了该选项框(左上角的关闭链接),可以按住 Alt 键的同时运行本插件来重新显示此选项框;
      2. 记得单击选项框右上角的链接来“保存设置”,这样下次运行时就不用重新设置了;
      3. 如果不希望每次运行时显示 GUI 选项框,可以勾选“下次运行时不显示此选项”,然后记得“保存设置”就行了;
      4. 如果希望每当选择网页上的文本时就立即朗读,请勾选“立即朗读当……”;
      5. 如果希望循环朗读选择的文本,请勾选“循环朗读”。

【注意】
      1. 首次运行会显示 GUI 选项框,如果没有看到,你可能要在“Internet 选项->安全->自定义级别”里设置不禁用“对未标记为可安全执行脚本的 ActiveX 控件初始化并执行脚本”,建议设置成提示。

      2. 默认安装的微软的 TTS 语音引擎音效可能不大令人满意,你可以上网去下载其它的语音引擎,比如 NeoSpeech 系列、ScanSoft 系列等等。

【更新】
      [2007-10-31] 加入循环朗读的功能。
      [2007-10-29] 修正"保存设置"链接在新窗口打开的问题。
      [2007-10-29] 修复太低的版本无法运行的问题,但会因此无法保存设置

[ 本帖最后由 Jingle 于 2007-10-31 14:22 编辑 ]


附件: SpeakOutGB.rar (2007-10-31 14:22, 12.79 K)
该附件被下载次数 364


图片附件: 2007-10-31_142125.png (2007-10-31 14:22, 9.26 K)

顶部
Passerby
大学四年级
Rank: 9Rank: 9Rank: 9
Moderator


GreenBrowser专家   论坛热心贡献奖  
UID 26
精华 11
积分 8320
帖子 7285
阅读权限 200
注册 2006-12-22
来自 China
状态 离线
发表于 2007-10-27 21:46  资料 主页 短消息 
大家都开始用external.gbGetIni()了么……




"Are you hot?"
"17 charisma."
顶部
wolfcm
大学四年级
Rank: 9Rank: 9Rank: 9


GreenBrowser专家   论坛热心贡献奖  
UID 122
精华 18
积分 2336
帖子 1136
阅读权限 200
注册 2006-12-25
状态 离线
发表于 2007-10-27 22:23  资料 短消息 
external.gbGet/SetIni()的参数放在GreenBrowser.ini里面是很不方便的

GUI做得真漂亮,佩服啊




顶部
蓝色海洋
初中一年级
Rank: 7Rank: 7Rank: 7



UID 2361
精华 0
积分 154
帖子 111
阅读权限 100
注册 2007-2-28
状态 离线
发表于 2007-10-28 18:57  资料 短消息 
好东东啊。好爽啊。

[ 本帖最后由 蓝色海洋 于 2007-10-28 19:00 编辑 ]
顶部
蓝色海洋
初中一年级
Rank: 7Rank: 7Rank: 7



UID 2361
精华 0
积分 154
帖子 111
阅读权限 100
注册 2007-2-28
状态 离线
发表于 2007-10-28 19:43  资料 短消息 
这个插件实在太棒了,我不的不在发个贴强赞一把。把GUI的位置怎么才能弄到右边呢,比较习惯那样的。
顶部
cornertree
小学二年级
Rank: 2



UID 10769
精华 0
积分 6
帖子 5
阅读权限 20
注册 2007-10-25
状态 离线
发表于 2007-10-29 19:57  资料 短消息 
运行脚本错误,难道是因为我用的老版本的GB?我的版本是3.40629
顶部
cornertree
小学二年级
Rank: 2



UID 10769
精华 0
积分 6
帖子 5
阅读权限 20
注册 2007-10-25
状态 离线
发表于 2007-10-29 20:07  资料 短消息 
在“Internet 选项->安全->自定义级别”里设置不禁用“对未标记为可安全执行脚本的 ActiveX 控件初始化并执行脚本”,建议设置成提示。

设置后提示“是否允许交互‘——确定后显示运行脚本错误,是不是某个设置太高了
顶部
Jingle
大学三年级
Rank: 9Rank: 9Rank: 9


UID 5287
精华 6
积分 1741
帖子 469
阅读权限 200
注册 2007-6-5
来自 广东
状态 离线
发表于 2007-10-29 21:18  资料 短消息 
使用到了 gbGetIni() 和 gbSetIni() 函数,这两个函数确实高版本才有,但不知道从哪个版本开始的

虽然可以改一下代码避免错误,但却失去“保存设置”的功能,觉得也不大好。
顶部
cornertree
小学二年级
Rank: 2



UID 10769
精华 0
积分 6
帖子 5
阅读权限 20
注册 2007-10-25
状态 离线
发表于 2007-10-29 22:46  资料 短消息 
,谢谢!新版本又要diy一遍,麻烦啊。呵呵
顶部
Hengzer
高中三年级
Rank: 8Rank: 8


论坛热心贡献奖  
UID 51
精华 1
积分 743
帖子 450
阅读权限 150
注册 2006-12-22
状态 离线
发表于 2007-10-31 21:42  资料 主页 短消息 
先支持一下 回头再看 呼呼...




顶部
 


当前时区 GMT+8, 现在时间是 2020-2-25 14:22
苏ICP备07001345号

    本论坛支付平台由支付宝提供
携手打造安全诚信的交易社区 Powered by Discuz! 5.0.0  © 2001-2006 Comsenz Inc.
Processed in 0.038255 second(s), 6 queries

清除 Cookies - 联系我们 - 5iGB.com - Archiver